Labels

Saturday, November 5, 2011

Linux Support for W_LAN chip set TI TNETW1130GVF ?

| Wireless Driver & Software

I bought a SAFECOM SWLCT-54125 802.11g+ Wireless LAN CardBus PC Card & am stuck, looking for ideas (Yes, stupid me, bought without checking compatability, tempted by price (17 GBP), must have been mad, Mea Culpa!): According to http://safecom.cn (Then type SAFECOM SWLCT-54125 into query box) It uses Chipset TI TNETW1130GVF http://focus.ti.com/docs/prod/folders/print/tnetw1130.html#technicaldocuments Medium-Access Controller (MAC) and Baseband Processor For Spread-Spectrum WLAN http://focus-webapps.ti.com/general/docs/sitesearch/searchsite.tsp?selectedTopic=1653260327&numRecords=25&searchTerm=tnetw1130&statusCode=null I hope there’s some chance, as the box features the Linux penguin, & quoting: http://focus.ti.com/general/docs/bcg/bcgprodcontent.tsp?templateId=6116&navigationId=12244&path=templatedata/cm/product/data/tnetw1130_main "All products submitted for 802.11g Wi-Fi certification will be tested against TNETW1130-based reference designs." TI Product announcement also mentions: Like TI’s ACX100 and ETW1100B, the TNETW1130 …. package, which is pin-for-pin compatible with TI’s previous generation WLAN MAC/baseband processor device. A diff -c of 2 x dmesg after boot -v , (with first a working USB2 card, & then reboot with WLAN card istead) shows: pcib2: cardbus0 requested memory range 0xfce00000-0xfcefffff: good ! cardbus0: Expecting link target, got 0x2c ! cardbus0: Resource not specified in CIS: id=10, size=2000 ! cardbus0: Resource not specified in CIS: id=14, size=20000 ! pcib2: cardbus0 requested memory range 0xfce00000-0xfcefffff: good ! found-> vendor=0x104c, dev=0×9066, revid=0×00 bus=4, slot=0, func=0 ! class=02-80-00, hdrtype=0×00, mfdev=0 cmdreg=0×0000, statreg=0×0210, cachelnsz=8 (dwords) ! lattimer=0xa8 (5040 ns), mingnt=0×00 (0 ns), maxlat=0×00 (0 ns) intpin=a, irq=11 powerspec 2 supports D0 D1 D2 D3 current D0 ! cardbus0: <network> at device 0.0 (no driver attached) I have 2 partitions on the laptop: 6.0 & 6.1-pre. I could change 6.1-pre to current if there’s any code to try ? I’m more used to dealing with 16 bit cards with pccardd -d -v on FreeBSD 4 & 5, & at a loss what to do. Might Project Evil be a last way out ? (MS emul. of drivers far as I recall) No way will I run Linux permanently on the laptop just to get the WLAN working (though I suppose I might do a temporary install to learn which driver & maybe find src/ to port, but I bet it wouldnt be that easy ? Progress Googling: http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Linux.Wireless.drivers.802.11ag.html http://acx100.sourceforge.net/ http://dev.kewl.org/acx100/ http://developers.slashdot.org/developers/03/07/21/1057231.shtml http://dev.kewl.org/acx100/acx100-6.0-REL-soyer.tgz http://dev.kewl.org/acx100/TEST/acx100-6.1.tgz OK, that lot seems (superficially at least) for the previous generation chip, but perhaps a good launch point ? Per their web I did: cd firmware && make && cd .. make make install echo ‘if_acx_load="YES"’ >> /boot/loader.conf gzip -c if_acx.4 > /usr/share/man/man4/acx.4.gz & saw: install -o root -g wheel -m 555 if_acx.ko /boot/modules kldxref /boot/modules reboot Still no extra interface, though Ive got pccard_enable="YES" in /etc/rc.conf Any Suggestions & comments very welcome ! Thanks. Julian — Julian Stacey. Consultant Unix Net & Sys. Eng., Munich. http://berklix.com

No comments:

Post a Comment